C9 으로 루비 작업을 하고 git으로 로컬 저장소로 클론 해왔을 때 루비 버전이 달라 에러가 발생했습니다.


이 때 해결하는 방법을 적습니다~


(아래의 포스팅은 맥 osX 를 기반으로 작성되었습니다.)



RVM (Ruby Version Manager)을 사용하시면 됩니다.


RVM에 관한 자세한 설명은 https://rvm.io/ 를 참고하시면 좋을 것 같아요.


간략히 말하면 루비의 버전을 관리를 도와주는 도구입니다.



실제로 루비를 설치할 때도  RVM을 사용해서 설치 가능하고, 이 방법이 좋다고 하더라고요.



우선 RVM을 설치해줍니다.



RVM 설치 방법은 위의 RVM 공식 사이트에 영어로 친절하게 설명되어 있습니다^^



우선 터미널 창을 여시고


gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3 7D2BAF1CF37B13E2069D6956105BD0E739499BDB


위의 명령어를 치셔서 GPG KEY를 설치합니다.


이 과정을 거치는 이유는 보안을 보장하기 위해 설치 패키지를 확인하는 데 사용되는 mpapisPublic(공용 키)키를 설치하기 위해서 입니다.



이 다음은 아래의 명령어를 터미널창에 치셔서, rvm을 설치합니다.


\curl -sSL https://get.rvm.io | bash



이렇게 설치를 끝내신 후 아래의 명령어를 치셔서 잘 설치 되었는지 확인합니다.


rvm -v


잘 설치 되었다면 아래와 비슷하게 나올 겁니다.


rvm -v 명령어는 rvm의 버젼을 확인하는 명령어입니다.



이제 모든 준비는 끝났습니다.


우선 c9에 가셔서 프로젝트의 루비의 버전을 확인합니다.


ruby -v 명령어로 루비 버전을 확인 가능합니다.



아직까지 C9 은 루비 버전 2.3.0 을 지원합니다. (현재는 안정 버전으로 2.4.2로 나와있습니다)


맥 OS X 에는 기본적으로 루비가 설치되어 있습니다. 하지만 그 버전이 굉장히 옛날 버전입니다.


실제로 루비를 한번도 설치 하지 않은 상태에서


ruby -v


명령어를 치셔서 확인 하실 수 있습니다.



위와 같은 식으로 말이죠.


(저는 최신 버전을 이미 깔아놓았기에 2.4.2 의 버전이 나옵니다~)



이처럼 컴퓨터의 디폴트 루비 버전과 c9이나 다른 방법으로 만든 루비 프로젝트의 루비 버전이 다르면 에러가 나게 됩니다.

(실제로 2.3.0 버전에서는 Bignum, Fixnum의 두개의 정수 클래스를 가지고 있다면, 2.4.0 부터는 Integer로 통합되었다고 합니다.)



이때 rvm으로 컴퓨터의 루비버전을 프로젝트의 루비 버전과 맞게 바꿔 주시면 에러 없이 즐코딩 가능합니다.

(반대로 프로젝트의 루비 버전을 바꿔 줄 수도 있을 겁니다. 다만 이때는 여러 가지 많이 만져줘야 해요.(그렇다고 알고 있습니다.. 어렵고 힘들다고))



이제부터 rvm을 사용합니다.


우선 rvm list 명령어로 사용가능한 루비 버전을 봅니다.

rvm list


저는 아래와 같이 나옵니다.


저는 현재 두개의 루비 버전이 깔려있네요.



제가 만든 c9 프로젝트의 루비 버전은 2.3.0 이니까 저는 2.3.0 을 깔 필요가 있습니다.


이 명령어는 아래와 같습니다.


rvm install 버전


저는 2.3.0이 필요하니 rvm install 2.3.0 을 쳤습니다.



시간이 꽤 걸립니다.


차분히 기다리면 설치가 됩니다.


루비 2.3.0 버전이 잘 설치 되었는 지 보기위해 다시 rvm list 명령어를 쳐봅시다.

오 2.3.0 버전이 생겨놨습니다.


저기서 => 는 현재 사용하고 있는 ruby 버전을 말하고 * 는 컴퓨터의 디폴트 버전을 말합니다.

저렇게 설치 한것만으로도 현재 2.3.0 버전을 사용할 수 있습니다.


한번 ruby -v 를 쳐보세요.

위와 같이 아까와 달라진 것을 확인할 수 있습니다.


만약 다른 버전을 사용하고 싶다면

rvm use 버전

위의 명령어를 치시면 됩니다.



위와 같이 rvm use 명령어를 통해 자유롭게 버전을 오고 갈 수 있습니다.


추가로 디폴트 루비 버전을 바꾸고 싶다면


rvm --default 버전


위의 명령어를 치시면 됩니다.


위와 같이 * 가 붙은 위치가 바뀐 것을 확인 하실 수 있습니다!



** 요약 **


설치된 사용 가능한 루비 목록 보기

rvm list

특정 버전의 루비 사용하기

rvm use 버전

트정 버전의 루비를 디폴트 버전으로 하기

rvm --default 버전




출처 : 

https://rvm.io/

http://wantknow.tistory.com/        원노님

https://www.ruby-lang.org/ko/news/2016/11/09/ruby-2-4-0-preview3-released/

'CODING > RUBY' 카테고리의 다른 글

루비 버전 관리 RVM 기본 사용법  (1) 2017.11.23
  1. 지우 2018.07.01 12:39

    엄청 대단한 일을 하고 계시는군요

+ Recent posts